
Contents for User Profile Editor Help

 
Introduction
 About User Profile Editor
 About User Profiles

How To...
 Manage User Profiles

Commands
 File Menu Commands



Contents for User Profile Editor Help

 
Introduction
 About User Profile Editor
 What Is User Profile Editor?
 The User Profile Editor Window
 About User Profiles
 What Is a User Profile?
 Mandatory and Personal User Profiles
 Default Profiles
How To...
 Manage User Profiles
 Creating a New User Profile
 Editing a User Profile
 Copying a User Profile
 Saving a User Profile
 Assigning User Profiles to User Accounts
Commands
 File Menu Commands
 New 
 Open 
 Save To Current Profile
 Save As User Default
 Save As System Default
 Save As File
 Exit



Contents for User Profile Editor Help

 
Introduction
 About User Profile Editor
 What Is User Profile Editor?
 The User Profile Editor Window
 About User Profiles

How To...
 Manage User Profiles

Commands
 File Menu Commands



Contents for User Profile Editor Help

 
Introduction
 About User Profile Editor
 About User Profiles
 What Is a User Profile?
 Mandatory and Personal User Profiles
 Default Profiles
How To...
 Manage User Profiles

Commands
 File Menu Commands



Contents for User Profile Editor Help

 
Introduction
 About User Profile Editor
 About User Profiles

How To...
 Manage User Profiles
 Creating a New User Profile
 Editing a User Profile
 Copying a User Profile
 Saving a User Profile
 Assigning User Profiles to User Accounts
Commands
 File Menu Commands



Contents for User Profile Editor Help

 
Introduction
 About User Profile Editor
 About User Profiles

How To...
 Manage User Profiles

Commands
 File Menu Commands
 New
 Open
 Save To Current Profile
 Save As User Default
 Save As System Default
 Save As File
 Exit



What Is a User Profile?

A user profile is a definition of the Windows NT configuration for a specific user or group of 
users. By default, each Windows NT workstation maintains a profile for each user who has 
logged on to the workstation, except for Guest accounts. Each user profile contains 
information about particular user's Windows NT configuration. Much of this information is 
about things the user can set, such as color scheme, screen savers, and mouse and 
keyboard layout. Other information is about things that can be set only by a Windows NT 
administrator, such as access to common program groups or network printers. 
For a description of user-specific information that is recorded in a user profile, choose one 
of the following topics:
 Program Manager
 File Manager
 Command Prompt
 Print Manager
 Control Panel Options
 Windows NT Accessories
 Third-Party Applications
 Online Help Bookmarks

See also
The User Profile Editor Window



Program Manager

All user-definable settings for Program Manager, including personal program groups and 
their properties, program items and their properties, and all settings saved by the Save 
Settings on Exit and Save Settings Now commands.



File Manager

All user-definable settings for File Manager, including network connections and everything 
saved by the Save Settings on Exit command.



Command Prompt

All user-definable settings for the command prompt, including fonts, colors, settings for the 
screen size buffer, and window position.



Print Manager

Network printer connections and all settings saved by the Save Settings on Exit command.



Control Panel Options

All user-specific settings. 
For the Color, Mouse, Desktop, Cursor, Keyboard, International, and Sound options, all 
settings are user-specific. For the System option, the only user-specific settings are the 
entries in the User Environment Variables box. The other Control Panel options have no 
user-specific settings.



Accessories

All user-specific application settings affecting the user's Windows NT configuration. 
Accessory applications include Calculator, Cardfile, Clock, Notepad, Paintbrush, and 
Terminal.



Third-party Windows NT Applications

Any application written specifically for Windows NT can be designed so that it tracks 
application settings on a user-by-user basis. If this user-specific information exists, it is 
saved in the user profile.



Online Help Bookmarks

Any bookmarks placed in the Windows NT Help system.



Mandatory and Personal User Profiles

Two types of user profiles can be created with User Profile Editor. For information on each 
type of user profile, choose the following buttons. 
 Mandatory User Profile
 Personal User Profile



Mandatory User Profile

A user profile that remains the same from one Windows NT logon session to the next. Users
cannot make any permanent changes to a mandatory user profile. 



Personal User Profile

A user profile that can be changed from one logon session to the next, depending on 
permissions specified in the user profile itself. 



Default Profiles

When Windows NT is running but nobody is logged on, or when a user is logged on but has 
no available user profile, Windows NT loads a default profile. For information on default 
profiles, choose one of the following topics:
 User Default Profile
 System Default Profile



User Default Profile

The user profile that is loaded:
When a user account does not have a profile assigned to it, and the user has never 

logged on to the current Windows NT computer.
When a user account's assigned profile cannot be accessed during logon (for 

example, if the server where the profile is stored is down), and the user has never logged on
to the current Windows NT computer.

When a user logs on to the Guest account.



System Default Profile

The user profile that is loaded when Windows NT is running and nobody is logged on. When
the Welcome dialog box is visible, the system default profile is loaded. 



What Is User Profile Editor?

User Profile Editor is a Windows NT administrative tool for creating a customized user 
profile. A customized user profile differs from the user profiles that Windows NT 
automatically creates and maintains in these ways:

A single user profile can be made available to a user from any computer on the 
network. 

A single user profile can be shared by a group of users who perform similar tasks. 
A custom user profile can limit a user's ability to change the user profile and to gain 

access to some commands in Program Manager. 
See Also
What Is a User Profile?
The User Profile Editor Window



Creating a New User Profile

When you create or edit a user profile, the changes you make also affect the account where
you are working. To keep your own user profile intact, it is a good idea to create a special 
Profile Administrator's account and log on to that account when you are managing user 
profiles. A Profile Administrator's account can be any account that is a member of the 
Domain Admins global group or the Administrators local group. 
To create a new user profile
1. Configure the Windows NT environment of your own computer until it is exactly as you 

want it for the intended users of the profile. Be sure to allow for different hardware and
software configurations that may be encountered by users of the profile. In particular, 
allow for different video displays, and maintain consistent program paths.

2. In the User Profile Editor window, configure the options as you want them. If you are 
not editing the user or system default profile, be sure to complete the Permitted To Use
Profile box.

3. From the File menu, choose the command for the way you want to save the profile. 

See Also
What Is a User Profile?
The User Profile Editor Window
Saving a User Profile
Assigning User Profiles to User Accounts



Allowing for Different Hardware and Software Configurations

Allow for the differing workstation configurations the user may encounter. For instance, the 
same application on different Windows NT computers may use a different path, or an 
application may not even be available on some computers. Hardware configurations may 
differ, too. Not all computers, for example, may use the same kind of pointing device. 
If the user is always going to be working at the same computer, be sure that the profile you
create accounts for differences between the user's computer and the one you are using to 
create or edit the profile.



Allowing for Different Video Displays

Lay out program groups using a computer that has the same type of video display that will 
be used by those who will be assigned the profile. Problems can occur if you don't. 
For example, if you lay out program groups using a super VGA screen and then assign the 
profile to users who have VGA screens, the users may find the screen boundaries awkward 
or unusable.



Maintaining Consistent Program Paths

The program path you specify for a program item must be valid for all Windows NT 
workstations where the user profile is used. Here are three ways to be sure that program 
paths are correct:

If your software license permits, put the application on a server. 
Install the application in the same directory on every workstation. 
Add the application directory to the user's path, and do not enter a pathname when 

you define the command line for the application's program item. 



Editing a User Profile

You can edit all the settings in the user profile, or you can edit only the options available in 
the User Profile Editor window. For the detailed procedure, choose one of the following 
topics:
Editing the Entire User Profile
Editing Only the Settings in the User Profile Editor Window



Editing the Entire User Profile

Editing the entire user profile is very similar to creating the profile in the first place. When 
you create or edit a user profile, the changes you make also affect the account where you 
are working. To keep your own user profile intact, it is a good idea to create a special Profile
Administrator's account and log on to that account when you are managing user profiles. A 
Profile Administrator's account can be any account that is a member of the Domain Admins 
global group or the Administrators local group. 
To edit an existing user profile
1. If you are editing a personal user profile (file extension .USR), make sure the user to 

whom the profile is assigned is logged off. 
2. Assign the profile to your Profile Administrator's account, and then log on to that 

account. 
3. Configure the Windows NT environment of your own computer until it is exactly as you 

want it for the intended users of the profile. Be sure to allow for different hardware and
software configurations that may be encountered by users of the profile. In particular, 
allow for different video displays, and maintain consistent program paths.

4. In the User Profile Editor window, configure the options as you want them. If you are 
not editing the user or system default profile, be sure to complete the Permitted To Use
Profile box.
Except for the Startup program group, the settings in the User Profile Editor do not 
have any effect on administrator accounts. For example, even if the Disable Run In File 
Menu option is selected, the administrator still has access to the Run command.

5. From the File menu, choose Save To Current Profile. 

See Also
What Is a User Profile?
The User Profile Editor Window
Saving a User Profile
Assigning User Profiles to User Accounts



Profile Administrator's Account

When you create or edit a user profile, the changes you make also affect the account where
you are working. To keep your own user profile intact, it is a good idea to create a special 
Profile Administrator's account and log on to that account when you are managing user 
profiles. A Profile Administrator's account can be any account that is a member of the 
Domain Admins global group or the Administrators local group. 



Saving an Edited Personal User Profile That Is Assigned to a User

When you edit a personal user profile that is already assigned to a user, you should save it 
under a new filename or a new pathname. If the user of the profile is logged on when you 
overwrite it, the original version of the profile will overwrite your modifications when the 
user logs off. 
After you have saved the edited personal user profile, update the User Profile Path assigned
to the user account in User Manager for Domains. The next time the user logs on, the new 
personal user profile is loaded.



Editing Only the Settings in the User Profile Editor Window

To edit only the settings in the User Profile Editor window
1. If you are editing a personal user profile (file extension .USR), make sure the user to 

whom the profile is assigned is logged off.
2. Assign the profile to your Profile Administrator's account, and then log on to that 

account. 
3. From the File Menu, choose Open. In the dialog box that appears, select the user profile

you want to change, and then choose the OK button.
4. In the User Profile Editor window, configure the options as you want them. 

Except for the Startup program group, the settings in the User Profile Editor do not 
have any effect on administrator accounts. For example, even if the Disable Run In File 
Menu option is selected, the administrator still has access to the Run command.

5. From the File menu, choose Save As File. Specify the drive, pathname, and filename 
you want, and then choose the OK button. 



Copying a User Profile

If you want to assign the same personal user profile to a number of users, it is best to make
copies of the profile and assign each copy to a different individual. 
To copy a user profile
1. From the File Menu, choose Open. In the dialog box that appears, select the user profile

you want to change, and then choose the OK button.
2. Choose the Browse button next to the Permitted to Use Profile box. In the User Browser

dialog box that appears, add the name of the user or group you want to assign the 
copy of the profile to. 

3. From the File menu, choose Save As File. Save the profile under a unique filename. 
Mandatory user profiles must have a file extension of .MAN; personal user profiles must
have a file extension of .USR.



Saving a User Profile

To save a user profile
1. From the File menu, choose the command for the way you want to save the profile: 

Save To Current Profile, Save As User Default, Save As System Default, or Save As File. 
2. If you choose Save As File, complete the Save As dialog box. Mandatory profiles must 

have a file extension of .MAN; personal user profiles must have a file extension of .USR.
When you edit a personal user profile that is already assigned to a user, it is a good 
idea to give the profile a new filename, a new pathname, or both. This precaution is 
unnecessary for a mandatory profile or for a profile that is not yet assigned to a user 
account.

See also
Assigning User Profiles to User Accounts
Save To Current Profile command
Save As User Default command
Save As System Default command
Save As File command



Assigning User Profiles to User Accounts

You assign user profiles to user accounts in User Manager for Domains.
Remember that mandatory user profiles can be assigned to any number of user accounts, 
but personal user profiles should each be assigned to only one user account.
Except for the Startup Group, settings in the User Profile Editor window do not affect 
administrator accounts. 



The User Profile Editor Window

For information on the individual elements of the User Profile Editor window, choose one of 
the following buttons. Use the scroll bar to see more buttons.
 Permitted to Use Profile
 Browse Button
 Program Manager Settings
 Disable Run in File Menu
 Disable Save Settings Menu Item and Never Save Settings
 Show Common Program Groups
 Startup Group
 Program Group Settings
 Lock button

 Unlock button
 For Unlocked Groups, Allow User To
 Make Any Change
 Create/Delete/Change Program Items
 Change All Program Item Properties
 Change Program Item Properties Except Command Line
 Allow User to Connect/Remove Connections in Print Manager
See Also
What Is User Profile Editor?
What Is a User Profile?



Permitted to Use Profile

Gives a user or a local or global group access to a user profile. This option does not assign 
the profile; it only gives the specified user or group the necessary permission to write to or 
read the profile. 



Browse Button

 Choose the Browse button to give a user or a local or global group the necessary file 
permissions to use the profile. 



Program Manager Settings

The options under Program Manager Settings specify a startup group and determine the 
user's access to some features in Program Manager.



Disable Run in File Menu

Prevents users from issuing the Run command on the File menu in Program Manager.
Selecting Disable Run In File Menu does not prevent users from starting programs from 
within other programs, running File Manager or the command prompt, or changing 
program-item command lines to run other programs. 



Disable Save Settings Menu Item and Never Save Settings

Prevents users from issuing the Save Settings on Exit and the Save Settings Now 
commands on the Options menu in Program Manager.



Show Common Program Groups

Makes common program groups available to the user of the profile. 
Common program groups are stored on a workstation and can be made available to any 
user who logs on to the workstation. Only an administrator can create or change common 
groups.



Startup Group

Specifies a startup program group. The program items in the startup group are started 
every time the user logs on.



Program Group Settings

The options under Program Group Setttings determine how much control the user has over 
personal program groups. Personal program groups are available only to the user or users 
of a particular profile. 
Personal program groups can be locked or unlocked. When a personal program group is 
locked, a user cannot change it in any way.
When a personal program group is unlocked, a user can change the program group and the
program items within that group, depending on the setting in For Unlocked Groups, Allow 
User To.



Lock button

Locks any personal program groups selected in the Unlocked Program Groups list and 
moves the names of the selected groups to the Locked Program list. When a personal 
program group is locked, a user cannot change it in any way.



Unlock button

Unlocks any personal program groups selected in the Locked Program list and moves the 
names of the selected groups to the Unlocked Program Groups list. When a personal 
program group is unlocked, a user can change the program group and the program items 
within that group, depending on the setting in For Unlocked Groups, Allow User To.



For Unlocked Groups, Allow User To

Determines the user's ability to make changes to the unlocked personal program groups. 



Make Any Change

Allows users to create, delete, or change unlocked personal program groups and program 
items in them.



Create/Delete/Change Program Items

Allows users to create, delete, and change program items in unlocked personal program 
groups. 
If this option is selected, users cannot create, delete, or change program groups.



Change All Program Item Properties

Allows users to change the properties of program items in unlocked personal program 
groups. 
If this option is selected, users cannot create or delete program items, nor can they create, 
delete, or change any personal program groups.



Change Program Item Properties Except Command Line

This option allows users to change all properties of program items in unlocked personal 
program groups except the Command Line entry in the Program Item Properties dialog box.
If this option is selected, users cannot create or delete program items, nor can they create, 
delete, or change program groups.



Allow User to Connect/Remove Connections in Print Manager

Allows users to add or remove network printer connections in Print Manager.
Clearing this option does not prevent users from establishing printer connections from the 
command prompt, nor does it prevent users from establishing printer connections using the
Run command on the File menu in Program Manager.



New 

Closes the current user profile and sets all options in the User Profile Editor window to the 
defaults for the user account where the profile is being created. 
If any changes to the current user profile have not been saved, User Profile Editor warns 
you that the changes will be lost and asks if you want to continue. 



Open 

Opens an existing user profile in the User Profile Editor window. 
For information on the Open dialog box that appears, choose one of the following topics:
 File Name
 Directories
 List Files of Type
 Drives
 Network button



File Name
 Enter the name of the file you want to open, or select one from the list below the File 

Name box. 



Directories
 If the directory path shown does not contain the file you want to open, select a different 

one in the box immediately below. 



List Files of Type

Specifies the files that are listed in the File Name box.
 Select All User Profiles (file extensions .MAN and .USR), Per-User Profile (.USR), or 

Mandatory Profile (.MAN).



Drives
 If the disk drive shown does not contain the file you want to open, select another from the 

list provided. 



Network button
 Choose the Network button to open a connection to the shared network directory that 

contains the user profile you want to open. 
For information on the Connect Network Drive dialog box that appears, choose the Help 
button or press F1 in the dialog box.



Save To Current Profile

Saves changes to the profile of the account where you are working.



Save As User Default

Saves the current user profile as the user default. 



Save As System Default

Saves the current user profile as the system default.



Save As File

Saves the current user profile as a file, which can then be assigned to one or more users. 
For information on the Save As dialog box that appears, choose one of the following topics:
 File Name
 Save File As Type
 Directories
 Drives
 Network



File Name
 Enter the filename under which you want to save the user profile. 
Mandatory user profiles must have the file extension .MAN; personal user profiles must 
have the file extension .USR. 



Directories
 If the directory path shown is not where you want to save the user profile, select a 

different one in the box immediately below. 



Save File As Type

Specifies the default file extension given to the filename of the user profile when you save 
it. 
 Select Per-User Profile ( file extension .USR), or Mandatory Profile (.MAN).



Drives
 If the disk drive shown is not where you want to save the user profile, select another from 

the list provided. 



Network button
 Choose the Network button to open a connection to the shared network directory where 

you want to save the user profile. 
For information on the Connect Network Drive dialog box that appears, choose the Help 
button or press F1 in the dialog box.



Exit

Quits User Profile Editor.



Contents

Lists User Profile Editor help topics.



Search for Help On

Presents an index of keywords from User Profile Editor help. You can list, select, and open 
help topics associated with individual keywords.



How to Use Help

Provides introductory information on the Windows NT help system.



About User Profile Editor

Provides version number, serial number, copyright, licensing, and other information about 
User Profile Editor. Also shows the amount of physical memory on your Windows NT 
computer.



Connect Network Drive

Use the Connect Network Drive dialog box to connect to shared directories available on the 
network. 
For information on the individual elements of this dialog box, choose one of the following 
topics:
 Drive
 Path
 Connect As
 Reconnect at Logon
 Expand Logon Domain at Startup
 Shared Directories



Drive

The drive that will be used for the network connection. Displays the lowest drive letter 
available.

To specify a different drive letter, select the Drive box and type the drive letter you 
want, or select the drive letter from the list in the Drive box.



Path

Shows the path of the share in the form \\computername\sharename.
To specify a path, select one from the list in the Path box, select a new network path 

from a computer in the Shared Directories list, or type the path in the Path box.



Connect As

Displays the username you are logged on as.
To connect to the share under a different username, select the Connect As box and 

type that username.



Reconnect at Logon
 To connect to the shared directory at each logon, select the Reconnect At Logon check 

box. 
To connect to the shared directory only during this Windows NT session, clear the 
Reconnect At Logon check box.



Expand Logon Domain at Startup

When cleared, shows only the highest-level view in the Shared Directories list whenever the
Connect Network Drive dialog box appears.
When selected, lists your logon domain first and shows each computer of that domain 
whenever the Connect Network Drive dialog box appears.



Shared Directories

Shows networks, domains, and computers. Can be expanded to show shared directories for 
a computer.

Double-click an item (network, domain, or server) to expand the list. Select a shared 
directory to place it in the Path box.



User Browser

Use the User Browser dialog box to make the current user profile available to an individual 
user or a local or global group.
Choose one of the following buttons for information about the dialog box:
 List Names From
 Names
 Add Button
 Show Users Button
 Members Button
 Search Button
 Add Name



List Names From

Displays the name of the domain or computer whose groups are shown in the Names box. 
To display groups and users in another domain or on another computer, select 

another domain or computer.



Names

Displays the groups or users belonging to the current domain or computer.
To add groups or users to the permissions list, select them in the Names box and 

choose the Add button.



Add Button
To add a group or user to the permissions list, select the appropriate name in the 

Names box and choose the Add button.



Show Users Button
To display the names of users belonging to the current domain or computer, choose 

the Show Users button.
The names are added to the Names box. 



Members Button
To list a group's members, select the group in the Names box, and then choose the 

Members button.



Search Button

To add a group or user, you must know the domain that contains the account for the group 
or user.

To find the domain to which a group or user belongs, choose the Search button.



Add Name

Displays the name of the group or user with permission to use the current user profile.
To add a groups or user to the Add Name box, select the appropriate name in the 

Names box, and then choose the Add button.
Or type the name directly in the Add Name box. If the account of the group or user is 

not located on the computer or domain shown by the List Names From box, specify the 
location. Type the computer or domain name followed by the group or user name and 
separate the names using a backslash, for instance, domainname\username.



Find Account

Use the Find Account dialog box to locate the domain of an account on a Windows NT 
Advanced Server network.
Choose one of the following buttons for information about the dialog box:
 Find User or Group
 Search All
 Search Only In
 Search Button
 Add Button



Find User or Group
In the Find User Or Group box, type the name of the group or user whose account you

want to find.



Search All
To search for the account in all the listed domains, select the Search All button.



Search Only In
To search for the account in one or more domains, select them in the Search Only In 

box.



Search Button
After specifying a group or user and the domains to search, choose the Search button

to start the search.



Add Button
To add the user or group to the Add Names box in the User Browser dialog box, select

the user or group in the Search Results box and then choose the Add button.



Local Group Membership

Displays the members of the local group selected in the User Browser dialog box.
To include the group in the Add Name box in the User Browser dialog box, choose the 

Add button.
To include one of the listed members in the Add Names box in the User Browser 

dialog box, select the name you want, and then choose the Add button.
On a Windows NT Advanced Server network, global groups that are members of a local 
group appear in the list.

To see a global group's members, select the group and choose the Members button.



Global Group Membership

Displays the members of the global group selected in the User Browser dialog box.
To include the group in the Add Name box in the User Browser dialog box, choose the 

Add button.
To include one of the listed members in the Add Names box in the User Browser 

dialog box, select the name you want, and then choose the Add button.




